Supported Browsers and Configurations

ASSA ABLOY Americas University eLearning sites support the following browsers and configurations.

The preferred browser for ASSA ABLOY University is Internet Explorer version 7.0 or higher.

Pop up blockers should be turned off.

If you are experiencing an issue with either the ASSA ABLOY Americas University site, or one of the courses, and are using another browser, it is suggested that you try Internet Explorer before contacting technical support.

ASSA ABLOY courses rely on the Adobe Flash player and as such are incompatible with Apple iOS devices such as the iPad and iPhone.